ARTICLE DETAIL

资讯详情

深耕网站建设、视觉设计与SEO优化的一线实战洞察。

MySql 1170-BLOB/TEXT 错误

MySql 1170-BLOB/TEXT 错误

 MySql  1170-BLOB/TEXT column 'id'used in key specification without a key length

原因:由于将主键id设置为 text类型,所以导致主键 的长度,没有设置。

解决方案:方案1:将主键id设置为varchar 类型的,设置对应的长度
方案2:如下图,点击后面的主键,在下方属性列设置id的长度即可保存
 

返回列表