ARTICLE DETAIL

资讯详情

深耕网站建设、视觉设计与SEO优化的一线实战洞察。

解决The Tomcat connector configured to listen on port 8080 failed to start

解决The Tomcat connector configured to listen on port 8080 failed to start

问题

启动javar报错,提示如下

Description:

The Tomcat connector configured to listen on port 8080 failed to start. The port may already be in use or the connector may be misconfigured.

Action:

Verify the connector’s configuration, identify and stop any process that’s listening on port 8080, or configure this application to listen on another port.

2024-02-04 11:57:51.189 INFO 6064 — [ main] o.s.s.concurrent.ThreadPoolTaskExecutor : Shutting down ExecutorService ‘applicationTaskExecutor’

Process finished with exit code 1

解决方案

  1. 调出命令终端
    win+r 并且输入cmd

  2. 查看某个端口(8080)的被占用情况

netstat -ano |findstr 8080

显示

C:\Users\gusijin>netstat -ano |findstr 8080TCP    0.0.0.0:8080           0.0.0.0:0              LISTENING       17244TCP    192.168.10.122:60391   14.116.242.250:8080    ESTABLISHED     14908TCP    [::]:8080              [::]:0                 LISTENING       17244TCP    [::1]:8080             [::1]:55341            TIME_WAIT       0TCP    [::1]:8080             [::1]:55342            TIME_WAIT       0C:\Users\gusijin>taskkill -PID 14908 -F
成功: 已终止 PID 为 14908 的进程。
  1. 根据进程号(14908)关闭进程即可
taskkill -PID 14908-F 

tasklist | findstr 17244
显示
java.exe 17244 Console 3 188,908 K

杀掉该进程 再次启动就OK啦

taskkill /f /t /im java.exe
返回列表